API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ConnectiveGeometryException Constructor (BentPlateGeometrySolverOperationStatus, String)

Initializes a new instance of the ConnectiveGeometryException class with connective geometry error message based on status.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ConnectiveGeometryException(
	BentPlateGeometrySolverOperationStatus status,
	string errorMessage
)

Parameters

status
Type: Tekla.Structures.ModelBentPlateGeometrySolverOperationStatus
Possible error statuses for geometry creation/modification commands.
errorMessage
Type: SystemString
The message that describes the error status.
See Also