![]() | ConnectiveGeometryException Class |
The ConnectiveGeometryException class represents an error that occurred during the ConnectiveGeometry creation or modification.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The ConnectiveGeometryException type exposes the following members.

Name | Description | |
---|---|---|
![]() | ConnectiveGeometryException |
Initializes a new instance of the ConnectiveGeometryException class with general connective geometry error message.
|
![]() | ConnectiveGeometryException(BentPlateGeometrySolverOperationStatus, String) |
Initializes a new instance of the ConnectiveGeometryException class with connective geometry error message based on status.
|

Name | Description | |
---|---|---|
![]() | OperationStatus |
Possible error statuses for geometry creation/modification commands.
|

Reference

SystemObject
SystemException
Tekla.Structures.ModelConnectiveGeometryException
Tekla.Structures.ModelExtensionIntersectsWithPlateException
Tekla.Structures.ModelFacePerpendicularToIntersectionLineException
Tekla.Structures.ModelFacesAtAnObtuseAngleException
Tekla.Structures.ModelFacesTooNearEachOtherException
Tekla.Structures.ModelGeneralConnectiveGeometryException
Tekla.Structures.ModelInvalidFacePointsException
Tekla.Structures.ModelInvalidRadiusException
Tekla.Structures.ModelPlateIntersectsWithIntersectionLineException
Tekla.Structures.ModelUndefinedCurveDirectionException
Tekla.Structures.ModelUnsupportedChamferException
SystemException
Tekla.Structures.ModelConnectiveGeometryException
Tekla.Structures.ModelExtensionIntersectsWithPlateException
Tekla.Structures.ModelFacePerpendicularToIntersectionLineException
Tekla.Structures.ModelFacesAtAnObtuseAngleException
Tekla.Structures.ModelFacesTooNearEachOtherException
Tekla.Structures.ModelGeneralConnectiveGeometryException
Tekla.Structures.ModelInvalidFacePointsException
Tekla.Structures.ModelInvalidRadiusException
Tekla.Structures.ModelPlateIntersectsWithIntersectionLineException
Tekla.Structures.ModelUndefinedCurveDirectionException
Tekla.Structures.ModelUnsupportedChamferException