API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ConnectiveGeometryGetNeighborSections Method

Gets neighbor sections of the geometrySection inside this ConnectiveGeometry.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public IList<GeometrySection> GetNeighborSections(
	GeometrySection geometrySection
)

Parameters

geometrySection
Type: Tekla.Structures.ModelGeometrySection
GeometrySection to get neighbors for.

Return Value

Type: IListGeometrySection
List of neighbor GeometrySection of the given GeometrySection.
See Also