API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ClashCheckDataClashTypeEnum Enumeration

An enumeration for the different clash types.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum ClashTypeEnum
Members
  Member nameValueDescription
CLASH_TYPE_INVALID0 The invalid clash type.
CLASH_TYPE_ISINSIDE1 One object is inside the other object.
CLASH_TYPE_EXACTMATCH2 The exact match clash type.
CLASH_TYPE_CLASH3 The unidentified clash type.
CLASH_TYPE_MINDISTANCE4 The minimum distance clash type.
CLASH_TYPE_FAILEDSOLID5 The failed solid clash type.
CLASH_TYPE_CUTTHROUGH6 The cut through clash type.
CLASH_TYPE_COMPLEXCLASH7 The complex clash type.
CLASH_TYPE_FAILEDTEST8 The failed test clash type.
See Also