API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BooleanPartSetOperativePart Method

Sets the part to operate with. The operative part's class member must be defined to be BooleanOperativeClass.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetOperativePart(
	Part Part
)

Parameters

Part
Type: Tekla.Structures.ModelPart
The operative part for the boolean.

Return Value

Type: Boolean
True on success.
See Also