API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BooleanPartOperativePart Property

The part that does the boolean operation. When Insert() is called, this field is overwritten with a new part instance which is a copy of the original operative part. This part has the same identifier as the boolean part. Modifications (such as profile change) have to be made through the part instance and not the boolean part instance. The operative part's class must be BooleanOperativeClass.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Part OperativePart { get; set; }

Property Value

Type: Part
See Also