BoltGroup Class

The BoltGroup class is an abstract base class for all bolt shapes, such as array, circle and XY list. See the Tekla Structures help file for further information about the attributes.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class BoltGroup : ModelObject

The BoltGroup type exposes the following members.

Constructors
  NameDescription
Public methodBoltGroup
Creates a new bolt group instance with the given shape.
Top
Properties
  NameDescription
Public propertyBlindHoleDepth
Gets or sets the blind hole depth.
Public propertyBolt
Indicates whether the instance is a bolt or just a hole.
Public propertyBoltHolesAttributes
The bolt holes attributes.
Public propertyBoltPositions
Gets the single bolt positions. All the bolt positions are in the XY-plane defined by the bolt group coordinate system. The given positions are in relation to the transformation plane in which the bolt group was selected.
Public propertyBoltSize
The size of the bolts in the group.
Public propertyBoltStandard
The standard of the bolt group.
Public propertyBoltType
The type of the bolt group.
Public propertyConnectAssemblies
Defines whether to connect a part or an assembly as a secondary part (false) or as a sub-assembly (true).
Public propertyCutLength
The cut length.
Public propertyEndPointOffset
The end point offset values of the bolt group.
Public propertyExtraLength
The extra length for the bolts.
Public propertyFirstPosition
The first position point.
Public propertyHole1
Indicates whether the hole 1 is used.
Public propertyHole2
Indicates whether the hole 2 is used.
Public propertyHole3
Indicates whether the hole 3 is used.
Public propertyHole4
Indicates whether the hole 4 is used.
Public propertyHole5
Indicates whether the hole 5 is used.
Public propertyHoleType
The special hole type: oversized, slotted, blind or no hole.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLength
The length. An extra variable that is only set when the bolt group is made of studs instead of bolts.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyNut1
Indicates whether the nut 1 is used in the assembly.
Public propertyNut2
Indicates whether the nut 2 is used in the assembly.
Public propertyOtherPartsToBolt
The other parts to be bolted (read-only).
Public propertyPartToBeBolted
The part to be bolted.
Public propertyPartToBoltTo
The part to bolt to.
Public propertyPlainHoleType
Gets or sets the plain hole type.
Public propertyPosition
The position attributes.
Public propertyRotateSlots
Gets or sets the rotation of the slots: odd, even or parallel.
Public propertySecondPosition
The second position point.
Public propertySlotOffsetX
Gets or sets the slotted hole offset X.
Public propertySlotOffsetY
Gets or sets the slotted hole offset Y.
Public propertySlottedHoleX
Gets or sets the X allowance of the slotted hole.
Public propertySlottedHoleY
Gets or sets the Y allowance of the slotted hole.
Public propertyStartPointOffset
The start point offset values of the bolt group.
Public propertyThreadInMaterial
Whether the thread goes inside the materal or not.
Public propertyTolerance
The hole tolerance.
Public propertyWasher1
Indicates whether the washer 1 is used in the assembly.
Public propertyWasher2
Indicates whether the washer 2 is used in the assembly.
Public propertyWasher3
Indicates whether the washer 3 is used in the assembly.
Top
Methods
  NameDescription
Public methodAddOtherPartToBolt
Adds the given part to the list of the other parts that should be bolted.
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the instance from the model database.
(Inherited from ModelObject.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetFatherPour
Returns the pour that the bolt group is associated to.
Public methodGetFatherPourUnit
Returns the pour unit that the bolt group is associated to.
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetOtherPartsToBolt
Returns an array list containing all the other parts that are bolted.
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSolid
Method for getting the solid information of the bolt group.
Public methodGetSolid(Boolean)
Method for getting the solid information of the bolt group.
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the model object instance into the model database.
(Inherited from ModelObject.)
Public methodModify
Modifies the model instance in the model database.
(Inherited from ModelObject.)
Public methodRemoveOtherPartToBolt
Removes the given part from the list of the other bolted parts.
Public methodSelect
Selects the model object instance from the model database.
(Inherited from ModelObject.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next