API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BoltArraySetBoltDistY Method

Sets the Y distance at the index defined by the argument.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetBoltDistY(
	int Index,
	double DistY
)

Parameters

Index
Type: SystemInt32
The index to the distance list.
DistY
Type: SystemDouble
The Y distance to be used.

Return Value

Type: Boolean
True if the distance was modified. False if the index is out of range.
See Also