API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BoltArrayAddBoltDistX Method

Adds an X distance to the bolt array.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool AddBoltDistX(
	double DistX
)

Parameters

DistX
Type: SystemDouble
The X distance to be added.

Return Value

Type: Boolean
True if the distance was added. Throws an OverflowException if there was no more space for the distance.
See Also