API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BentPlateGeometrySolverRemoveLeg Method

Removes a polygon section which is the end section, from this ConnectiveGeometry including extensions and cylindrical surface.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ConnectiveGeometry RemoveLeg(
	ConnectiveGeometry geometry,
	GeometrySection legSection
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
ConnectiveGeometry used to remove a connection.
legSection
Type: Tekla.Structures.ModelGeometrySection
Leg GeometrySection to remove.

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when the supplied legSection is invalid leg section or geometry is a stand-alone bend geometry, meaning that the first GeometrySection is a BendSurfaceNode.
See Also