API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BentPlateGeometrySolverAddLeg Method (ConnectiveGeometry, LineSegment, Contour, LineSegment, Double)

Appends a polygon section to this ConnectiveGeometry, using the specified connection points and radius for the cylindrical connection.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ConnectiveGeometry AddLeg(
	ConnectiveGeometry geometry,
	LineSegment segment1,
	Contour polygon,
	LineSegment segment2,
	double radius
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
ConnectiveGeometry used to create a connection with.
segment1
Type: Tekla.Structures.Geometry3dLineSegment
the two connection points on this instance geometry
polygon
Type: Tekla.Structures.ModelContour
the polygonal contour to add to this geometry
segment2
Type: Tekla.Structures.Geometry3dLineSegment
the two connection points on polygon geometry
radius
Type: SystemDouble
the specified radius for the connecting cylindrical section

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not create or modify ConnectiveGeometry instance.
ArgumentExceptionThrown when geometry is a stand-alone bend geometry, meaning that the first GeometrySection is a BendSurfaceNode.
See Also