API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BaseWeldWeldTypeEnum Enumeration

The weld types.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum WeldTypeEnum
Members
  Member nameValueDescription
WELD_TYPE_NONE0 No weld type.
WELD_TYPE_EDGE_FLANGE1 The edge-flange weld.
WELD_TYPE_SQUARE_GROOVE_SQUARE_BUTT2 The square-groove (square butt) weld.
WELD_TYPE_BEVEL_GROOVE_SINGLE_V_BUTT3 The bevel-groove (single-V butt) weld.
WELD_TYPE_BEVEL_GROOVE_SINGLE_BEVEL_BUTT4 The bevel-groove (single-bevel butt) weld.
WELD_TYPE_SINGLE_V_BUTT_WITH_BROAD_ROOT_FACE5 The single-V butt weld with broad root face.
WELD_TYPE_SINGLE_BEVEL_BUTT_WITH_BROAD_ROOT_FACE6 The single-bevel butt weld with broad root face.
WELD_TYPE_U_GROOVE_SINGLE_U_BUTT7 The U-groove (single U-butt) weld.
WELD_TYPE_J_GROOVE_J_BUTT8 The J-groove (single J-butt) weld.
WELD_TYPE_BEVEL_BACKING9 The bevel backing weld.
WELD_TYPE_FILLET10 The fillet weld.
WELD_TYPE_PLUG11 The plug weld.
WELD_TYPE_SPOT12 The spot weld.
WELD_TYPE_SEAM13 The seam weld.
WELD_TYPE_SLOT14 The slot weld.
WELD_TYPE_FLARE_BEVEL_GROOVE15 The flare-bevel-groove weld.
WELD_TYPE_FLARE_V_GROOVE16 The flare V-groove weld.
WELD_TYPE_CORNER_FLANGE17 The corner-flange weld.
WELD_TYPE_PARTIAL_PENETRATION_SINGLE_BEVEL_BUTT_PLUS_FILLET18 The partial penetration (single-bevel butt + fillet) weld.
WELD_TYPE_PARTIAL_PENETRATION_SQUARE_GROOVE_PLUS_FILLET19 The partial penetration (square groove + fillet) weld.
WELD_TYPE_MELT_THROUGH20 The melt-through weld.
STEEP_FLANKED_BEVEL_GROOVE_SINGLE_V_BUTT21 The steep flanked bevel groove single-V butt weld.
STEEP_FLANKED_BEVEL_GROOVE_SINGLE_BEVEL_BUTT22 The steep flanked bevel groove single-bevel butt weld.
WELD_TYPE_EDGE23 The edge weld.
WELD_TYPE_ISO_SURFACING24 The ISO surfacing weld.
WELD_TYPE_FOLD25 The fold weld.
WELD_TYPE_INCLINED26 The inclined weld.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.