API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BaseRebarGroupExcludeTypeEnum Enumeration

The different ways to exclude reinforcing bars from the group.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum ExcludeTypeEnum
Members
  Member nameValueDescription
EXCLUDE_TYPE_NONE1 All the reinforcing bars are included.
EXCLUDE_TYPE_FIRST2 The first reinforcing bar is not to be created to the group.
EXCLUDE_TYPE_LAST3 The last reinforcing bar is not to be created to the group.
EXCLUDE_TYPE_BOTH4 The first and last reinforcing bars are not to be created to the group.
See Also