API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BasePointGetCoordinateSystem Method

Gets the coordinate system of the base point.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public CoordinateSystem GetCoordinateSystem(
	BasePointCoordinateSystemType CoordsysType = BasePointCoordinateSystemType.GLOBAL
)

Parameters

CoordsysType (Optional)
Type: Tekla.Structures.ModelBasePointCoordinateSystemType
Optional: Type of the coordinate system.

Return Value

Type: CoordinateSystem
The coordinate system of the base point.
See Also