API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BasePointConvertFromBasePoint Method (BasePoint, Point)

Converts the given base point point to local point.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static Point ConvertFromBasePoint(
	BasePoint basePoint,
	Point point
)

Parameters

basePoint
Type: Tekla.Structures.ModelBasePoint
The base point, from which the point is converted from.
point
Type: Tekla.Structures.Geometry3dPoint
The point to be converted.

Return Value

Type: Point
On success, the converted value. Otherwise the original value.
See Also