API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BasePointConvertFromBasePoint Method (Point)

Converts the given this base points point to local point.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Point ConvertFromBasePoint(
	Point point
)

Parameters

point
Type: Tekla.Structures.Geometry3dPoint
The point to be converted.

Return Value

Type: Point
On success, the converted value. Otherwise the original value.
See Also