API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BasePoint Class

The BasePoint class provides base point related functionalities. Base points can be retrieved using ProjectInfo class.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelBasePoint

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class BasePoint

The BasePoint type exposes the following members.

Constructors
  NameDescription
Public methodBasePoint(String)
Initializes a new instance of the BasePoint class.
Public methodBasePoint(Int32, Guid, String, String, String, String, Double, Double, Double, Double, Double, Double, Double, Double, Double, Boolean, Boolean)
Initializes a new instance of the BasePoint class.
Top
Properties
  NameDescription
Public propertyAngleToNorth
Gets or sets the angle to north in radians.
Public propertyCoordinateSystem
Gets or sets the coordinate system.
Public propertyDescription
Gets or sets the description.
Public propertyEastWest
Gets or sets the east-west.
Public propertyElevation
Gets or sets the elevation.
Public propertyGuid
Gets or sets the guid.
Public propertyId
Gets or sets the id.
Public propertyInitialGuid
Gets or sets the initial guid. A metadata field to store for example some external applications base point guid. Not used in itself in any functionality.
Public propertyIsCurrentBasePoint
Gets or sets the value indicating if this base point is the current base point.
Public propertyIsLocked
Gets or sets the value indicating if this base point is locked.
Public propertyIsProjectBasePoint
Gets or sets the value indicating if this base point is the project base point.
Public propertyIsScopedCurrentBasePoint
Gets or sets the value indicating whether this base point is the scoped current base point.
Public propertyLatitude
Gets or sets the latitude.
Public propertyLocationInModelX
Gets or sets the location in model x.
Public propertyLocationInModelY
Gets or sets the location in model y.
Public propertyLocationInModelZ
Gets or sets the location in model z.
Public propertyLongitude
Gets or sets the longitude.
Public propertyName
Gets or sets the name.
Public propertyNorthSouth
Gets or sets the north-south.
Top
Methods
  NameDescription
Public methodConvertFromBasePoint(Point)
Converts the given this base points point to local point.
Public methodStatic memberConvertFromBasePoint(BasePoint, Point)
Converts the given base point point to local point.
Public methodConvertToBasePoint(Point)
Converts the given local point to this base point.
Public methodStatic memberConvertToBasePoint(BasePoint, Point)
Converts the given local point to given base point.
Public methodDelete
Deletes the base point from the model database.
Public methodGetCompoundPlaneAngleLatitude
Gets the Latitude as a compound plane angle.
Public methodGetCompoundPlaneAngleLongitude
Gets the Longitude as a compound plane angle.
Public methodGetCoordinateSystem
Gets the coordinate system of the base point.
Public methodInsert
Inserts the base point into the model database.
Public methodModify
Modifies the base point in the model database.
Public methodSetAsCurrent
Sets this base point as current base point point until the token is disposed of. Can be used for example when retrieving report values according to this base point.
Top
Examples
The following example gets the project information and shows the value of the Name property in a message dialog:
using Tekla.Structures.Model;

public class Example
{
    private void InsertBasePointExample()
    {
        var BasePoint = new BasePoint(
            0, // The id. Use zero when creating new
            Guid.Empty, // The guid. Use Guid.Empty when creating new
            Guid.Empty, // The initial guid. A metadata field
            "Base point name",
            "Base point description",
            "Base point coordinate system",
            1000.0, // North-South value
            2000.0, // East-West value
            3000.0, // Elevation value
            4000.0, // Latitude value
            5000.0, // Longitude value
            6000.0, // Base points X location in model
            7000.0, // Base points Y location in model
            8000.0, // Base points Z location in model
            (45 * Math.PI / 180), // Angle to north value in radians
            false, // Boolean indicating if this base point is project base point
            false); // Boolean indicating if this base point is current base point

        BasePoint.Insert();
    }

    private void GetBasePointsExample()
    {
        var BasePoints = ProjectInfo.GetBasePoints();
    }

    private void GetBasePointByGuidExample()
    {
        Guid BasePointGuid = new Guid("TheGuidOfTheBasePoint");
        var BasePoints = ProjectInfo.GetBasePointByGuid(BasePointGuid);
    }

    private void GetBasePointByNameExample()
    {
        Guid BasePointGuid = new Guid("TheNameOfTheBasePoint");
        var BasePoints = ProjectInfo.GetBasePointByGuid(BasePointGuid);
    }
}
See Also