API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BaseComponentSetAttribute Method (String, Double)

Sets the attribute's value to the given value.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public void SetAttribute(
	string AttrName,
	double DValue
)

Parameters

AttrName
Type: SystemString
The name of the attribute.
DValue
Type: SystemDouble
The double value of the attribute.
See Also