API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BaseComponentGetAttribute Method (String, String)

Retrieves the attribute with the given name.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool GetAttribute(
	string AttrName,
	ref string StrValue
)

Parameters

AttrName
Type: SystemString
The name of the attribute.
StrValue
Type: SystemString
A string for the return value.

Return Value

Type: Boolean
True if successful.
See Also