API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

VectorMultiply Operator (Double, Vector)

Calculates the multiplication of the given vector with the given scalar.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static Vector operator *(
	double Multiplier,
	Vector Vector
)

Parameters

Multiplier
Type: SystemDouble
The scalar to multiply the vector with.
Vector
Type: Tekla.Structures.Geometry3dVector
The vector to be multiplied.

Return Value

Type: Vector
The new vector that is the multiplication of the vector and the scalar.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.