API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

VectorNormalize Method

Normalizes the vector using the length 1.0 (the length of a unit vector).

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public double Normalize()

Return Value

Type: Double
The normalized vector's length.
See Also