API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

VectorGetAngleBetween Method

Gets the angle (in radians) between the current vector and the given vector.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public double GetAngleBetween(
	Vector Vector
)

Parameters

Vector
Type: Tekla.Structures.Geometry3dVector
The vector to be used.

Return Value

Type: Double
The angle between the vectors in radians.
See Also