Vector Class

The Vector class defines a direction and magnitude from the current origin.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Vector : Point

The Vector type exposes the following members.

Constructors
  NameDescription
Public methodVector
Instantiates a zero length vector.
Public methodVector(Point)
Instatiates a new vector with the given point.
Public methodVector(Double, Double, Double)
Instantiates a vector with the given coordinates.
Top
Methods
  NameDescription
Public methodCompareTo
Compares two points. To use binarysearch somekind of sorting should be used.
(Inherited from Point.)
Public methodCross(Vector)
Returns a new cross product vector of the current vector and the given vector.
Public methodStatic memberCross(Vector, Vector)
Returns a new cross product vector of the given two vectors.
Public methodDot(Vector)
Returns a dot product of the current vector and the given vector.
Public methodStatic memberDot(Vector, Vector)
Returns a dot product of the given two vectors.
Public methodEquals
Returns true if the current object and the given object are equal.
(Inherited from Point.)
Public methodGetAngleBetween
Gets the angle (in radians) between the current vector and the given vector.
Public methodGetHashCode
Returns a hash code for the point. Notice, in extremely rare cases, you might not get the same hash code for two points even though they are considered equal! This should, however, happen only in extremely rare cases!
(Inherited from Point.)
Public methodGetLength
Gets the length (magnitude) of a vector.
Public methodGetNormal
Returns a new normalized equivalent of the current vector.
Public methodNormalize
Normalizes the vector using the length 1.0 (the length of a unit vector).
Public methodNormalize(Double)
Normalizes the vector using the given length.
Public methodToString
Formats the 3D vector into a string with fixed decimals, in the following way: "(X, Y, Z)".
(Overrides PointToString.)
Public methodTranslate
Translates the point using the given vector.
(Inherited from Point.)
Public methodZero
Zeros all the members of the point.
(Inherited from Point.)
Top
Operators
  NameDescription
Public operatorStatic memberMultiply(Double, Vector)
Calculates the multiplication of the given vector with the given scalar.
Public operatorStatic memberMultiply(Vector, Double)
Calculates the multiplication of the given vector with the given scalar.
Top
Fields
  NameDescription
Public fieldX
The X-coordinate of the point.
(Inherited from Point.)
Public fieldY
The Y-coordinate of the point.
(Inherited from Point.)
Public fieldZ
The Z-coordinate of the point.
(Inherited from Point.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next