Vector Class

The Vector class defines a direction and magnitude from the current origin.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Vector : Point

The Vector type exposes the following members.

Constructors
  NameDescription
Public methodVector
Instantiates a zero length vector.
Public methodVector(Point)
Instatiates a new vector with the given point.
Public methodVector(Double, Double, Double)
Instantiates a vector with the given coordinates.
Top
Methods
  NameDescription
Public methodCross(Vector)
Returns a new cross product vector of the current vector and the given vector.
Public methodStatic memberCross(Vector, Vector)
Returns a new cross product vector of the given two vectors.
Public methodDot(Vector)
Returns a dot product of the current vector and the given vector.
Public methodStatic memberDot(Vector, Vector)
Returns a dot product of the given two vectors.
Public methodGetAngleBetween
Gets the angle (in radians) between the current vector and the given vector.
Public methodGetLength
Gets the length (magnitude) of a vector.
Public methodGetNormal
Returns a new normalized equivalent of the current vector.
Public methodNormalize
Normalizes the vector using the length 1.0 (the length of a unit vector).
Public methodNormalize(Double)
Normalizes the vector using the given length.
Public methodToString
Formats the 3D vector into a string with fixed decimals, in the following way: "(X, Y, Z)".
(Overrides PointToString.)
Top
Operators
  NameDescription
Public operatorStatic memberMultiply(Double, Vector)
Calculates the multiplication of the given vector with the given scalar.
Public operatorStatic memberMultiply(Vector, Double)
Calculates the multiplication of the given vector with the given scalar.
Top
Fields
  NameDescription
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next