API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProjectionLineToPlane Method

Returns a new line which is a projection of the given line onto the given plane.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static Line LineToPlane(
	Line Line,
	GeometricPlane Plane
)

Parameters

Line
Type: Tekla.Structures.Geometry3dLine
The line to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.

Return Value

Type: Line
The new projection line.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.