ProjectionLineSegmentToPlane Method

Returns a new line segment which is a projection of the given line segment onto the given plane.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public static LineSegment LineSegmentToPlane(
	LineSegment LineSegment,
	GeometricPlane Plane
)

Parameters

LineSegment
Type: Tekla.Structures.Geometry3dLineSegment
The line segment to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.

Return Value

Type: LineSegment
The new projection line segment.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next