API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolymeshEdgeTypeEnum Enumeration

The type of the polymesh edge. This should always correspond 1:1 with geometry::IndirectEdge_s::EdgeType_e on the Tekla Structures Core side

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public enum PolymeshEdgeTypeEnum
Members
  Member nameValueDescription
VISIBLE_EDGE1 Explicitly states that this edge is visible
INVISIBLE_EDGE2 For hiding edges in visualizations
See Also