API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Point Constructor (Double, Double, Double)

Instantiates a point with the given coordinates.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Point(
	double X,
	double Y,
	double Z
)

Parameters

X
Type: SystemDouble
The X-coordinate to be used.
Y
Type: SystemDouble
The Y-coordinate to be used.
Z
Type: SystemDouble
The Z-coordinate to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.