API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Point Constructor (Double, Double)

Instantiates a point with the given coordinates and zero Z-coordinate.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Point(
	double X,
	double Y
)

Parameters

X
Type: SystemDouble
The X-coordinate to be used.
Y
Type: SystemDouble
The Y-coordinate to be used.
See Also