API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ParallelVectorToVector Method (Vector, Vector, Double)

Returns true if the given vectors are parallel within the given angular tolerance.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool VectorToVector(
	Vector Vector1,
	Vector Vector2,
	double Tolerance
)

Parameters

Vector1
Type: Tekla.Structures.Geometry3dVector
The first vector to be used.
Vector2
Type: Tekla.Structures.Geometry3dVector
The second vector to be used.
Tolerance
Type: SystemDouble
The angular tolerance (in radians) to be used.

Return Value

Type: Boolean
True if the given vectors are parallel within the given tolerance.
See Also