API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ParallelLineToPlane Method (Line, GeometricPlane)

Returns true if the given line and plane are parallel.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool LineToPlane(
	Line Line,
	GeometricPlane Plane
)

Parameters

Line
Type: Tekla.Structures.Geometry3dLine
The line to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.

Return Value

Type: Boolean
True if the given line and plane are parallel.
See Also