API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ParallelLineSegmentToPlane Method (LineSegment, GeometricPlane, Double)

Returns true if the given line segment and plane are parallel within the given angular tolerance.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool LineSegmentToPlane(
	LineSegment LineSegment,
	GeometricPlane Plane,
	double Tolerance
)

Parameters

LineSegment
Type: Tekla.Structures.Geometry3dLineSegment
The line segment to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.
Tolerance
Type: SystemDouble
The angular tolerance (in radians) to be used.

Return Value

Type: Boolean
True if the given line segment and plane are parallel within the given tolerance.
See Also