API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ParallelLineSegmentToLineSegment Method (LineSegment, LineSegment)

Returns true if the given line segments are parallel.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool LineSegmentToLineSegment(
	LineSegment LineSegment1,
	LineSegment LineSegment2
)

Parameters

LineSegment1
Type: Tekla.Structures.Geometry3dLineSegment
The first line segment to be used.
LineSegment2
Type: Tekla.Structures.Geometry3dLineSegment
The second line segment to be used.

Return Value

Type: Boolean
True if the given line segments are parallel.
See Also