API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Parallel Class

The Parallel class contains methods for testing the parallelism of geometric objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dParallel

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public static class Parallel
Methods
  NameDescription
Public methodStatic memberLineSegmentToLineSegment(LineSegment, LineSegment)
Returns true if the given line segments are parallel.
Public methodStatic memberLineSegmentToLineSegment(LineSegment, LineSegment, Double)
Returns true if the given line segments are parallel within the given angular tolerance.
Public methodStatic memberLineSegmentToPlane(LineSegment, GeometricPlane)
Returns true if the given line segment and plane are parallel.
Public methodStatic memberLineSegmentToPlane(LineSegment, GeometricPlane, Double)
Returns true if the given line segment and plane are parallel within the given angular tolerance.
Public methodStatic memberLineToLine(Line, Line)
Returns true if the given lines are parallel.
Public methodStatic memberLineToLine(Line, Line, Double)
Returns true if the given lines are parallel within the given angular tolerance.
Public methodStatic memberLineToPlane(Line, GeometricPlane)
Returns true if the given line and plane are parallel.
Public methodStatic memberLineToPlane(Line, GeometricPlane, Double)
Returns true if the given line and plane are parallel within the given angular tolerance.
Public methodStatic memberPlaneToPlane(GeometricPlane, GeometricPlane)
Returns true if the given planes are parallel.
Public methodStatic memberPlaneToPlane(GeometricPlane, GeometricPlane, Double)
Returns true if the given planes are parallel within the given angular tolerance.
Public methodStatic memberVectorToPlane(Vector, GeometricPlane)
Returns true if the given vector and plane are parallel.
Public methodStatic memberVectorToPlane(Vector, GeometricPlane, Double)
Returns true if the given vector and plane are parallel within the given angular tolerance.
Public methodStatic memberVectorToVector(Vector, Vector)
Returns true if the given vectors are parallel.
Public methodStatic memberVectorToVector(Vector, Vector, Double)
Returns true if the given vectors are parallel within the given angular tolerance.
Top
See Also