![]() | OBBShortestSegmentTo Method (Point) |
Calculates the shortest LineSegment from OBB to the given point.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

Parameters
- point
- Type: Tekla.Structures.Geometry3dPoint
Point to calculate against.
Return Value
Type: LineSegmentShortest LineSegment from OBB to the given point.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when null is assigned to the point parameter. |