API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBShortestSegmentTo Method (LineSegment)

Calculates the shortest LineSegment from OBB to the given LineSegment.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public LineSegment ShortestSegmentTo(
	LineSegment lineSegment
)

Parameters

lineSegment
Type: Tekla.Structures.Geometry3dLineSegment
LineSegment to calculate against

Return Value

Type: LineSegment
Shortest LineSegment from OBB to the given LineSegment.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the lineSegment parameter.
See Also