API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBShortestSegmentTo Method (Line)

Calculates the shortest LineSegment from OBB to the given Line.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public LineSegment ShortestSegmentTo(
	Line line
)

Parameters

line
Type: Tekla.Structures.Geometry3dLine
Line to calculate against

Return Value

Type: LineSegment
Shortest LineSegment from OBB to the given Line.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the line parameter.
See Also