API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBSetExtent Method (Double)

Sets the extents to the OBB.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public void SetExtent(
	double[] extent
)

Parameters

extent
Type: SystemDouble
Three element array of the OBB extents (half-lengths of the edges).
Exceptions
ExceptionCondition
ArgumentExceptionThrown when setting the extent fails.
See Also