API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBSetAxis Method (Vector)

Sets the Axis to the OBB.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public void SetAxis(
	Vector[] axis
)

Parameters

axis
Type: Tekla.Structures.Geometry3dVector
Three element array of unit-length vectors parallel the axis of the OBB.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when setting the axis fails.
See Also