![]() | OBBIntersects Method (GeometricPlane) |
Tests if current OBB intersects with the given GeometricPlane
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

Parameters
- geometricPlane
- Type: Tekla.Structures.Geometry3dGeometricPlane
GeometricPlane to test against
Return Value
Type: BooleanTrue if the OBB intersects with the given GeometricPlane, otherwise false

Exception | Condition |
---|---|
ArgumentNullException | Thrown when null is assigned to the geometricPlane parameter. |