API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBDistanceTo Method (Point)

Calculates the distance from OBB to given point.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public double DistanceTo(
	Point point
)

Parameters

point
Type: Tekla.Structures.Geometry3dPoint
Point to calculate against.

Return Value

Type: Double
Distance from OBB to given point.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the point parameter.
See Also