API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBBClosestPointTo Method (LineSegment)

Calculates the closest point in OBB to given LineSegment.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Point ClosestPointTo(
	LineSegment lineSegment
)

Parameters

lineSegment
Type: Tekla.Structures.Geometry3dLineSegment
LineSegment to calculate against.

Return Value

Type: Point
Closest point in OBB to given LineSegment.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the lineSegment parameter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.