API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBB Constructor (Point, Vector, Vector, Vector, Double, Double, Double)

Initializes a new instance of the OBB class.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public OBB(
	Point center,
	Vector axis0,
	Vector axis1,
	Vector axis2,
	double extent0,
	double extent1,
	double extent2
)

Parameters

center
Type: Tekla.Structures.Geometry3dPoint
Center point of the OBB
axis0
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to one axis of the OBB.
axis1
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to the second axis of the OBB.
axis2
Type: Tekla.Structures.Geometry3dVector
Unit-length vector parallel to the third axis of the OBB.
extent0
Type: SystemDouble
The extent (half-length) of the side parallel to axis one.
extent1
Type: SystemDouble
The extent (half-length) of the side parallel to axis two.
extent2
Type: SystemDouble
The extent (half-length) of the side parallel to axis three.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when initialization fails.
See Also