API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBB Constructor (Point, Vector, Double)

Initializes a new instance of the OBB class.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public OBB(
	Point center,
	Vector[] axis,
	double[] extent
)

Parameters

center
Type: Tekla.Structures.Geometry3dPoint
Center point of the OBB.
axis
Type: Tekla.Structures.Geometry3dVector
Three element array of unit-length vectors parallel the axis of the OBB.
extent
Type: SystemDouble
Three element array of the OBB extents (half-lengths of the edges).
Exceptions
ExceptionCondition
ArgumentExceptionThrown when initialization fails.
See Also