API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OBB Constructor (OBB)

Initializes a new instance of the OBB class.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public OBB(
	OBB obb
)

Parameters

obb
Type: Tekla.Structures.Geometry3dOBB
OBB to be copied.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when initialization fails.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.