API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MatrixMultiply Operator (Matrix, Matrix)

Multiplies (combines) two transformation matrices.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static Matrix operator *(
	Matrix B,
	Matrix A
)

Parameters

B
Type: Tekla.Structures.Geometry3dMatrix
The transformation matrix which is applied second.
A
Type: Tekla.Structures.Geometry3dMatrix
The transformation matrix which is applied first.

Return Value

Type: Matrix
The new compound transformation matrix.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.