API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LineSegment Constructor (Point, Point)

Instantiates a line segment with the given points.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public LineSegment(
	Point Point1,
	Point Point2
)

Parameters

Point1
Type: Tekla.Structures.Geometry3dPoint
The starting point to be used.
Point2
Type: Tekla.Structures.Geometry3dPoint
The end point to be used.
See Also