![]() | LineSegment Class |
The LineSegment class represents a single finite segment of a line in 3D space. See Line
for the implementation of a straight line.

Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1

The LineSegment type exposes the following members.

Name | Description | |
---|---|---|
![]() | LineSegment |
Instantiates a line segment with both the starting point and the end point zeroed.
|
![]() | LineSegment(Point, Point) |
Instantiates a line segment with the given points.
|

Name | Description | |
---|---|---|
![]() | EndPoint |
Gets the end point of the line segment
|
![]() | Point1 |
Gets the start point of the line segment
|
![]() | Point2 |
Gets the end point of the line segment
|
![]() | StartPoint |
Gets the start point of the line segment
|

Name | Description | |
---|---|---|
![]() | Clone |
Creates a copy of itself
|
![]() | Equals(Object) |
Returns true if the objects are equal.
(Overrides ObjectEquals(Object).) |
![]() | Equals(ICurve) |
Returns true if the other curve is a line segment equal to this
|
![]() | GetDirectionVector |
Returns a new unit direction vector of a line segment.
|
![]() | GetHashCode |
Returns a hash code for a line segment.
Notice, in extremely rare cases, you might not get the same
hash code for two line segments even though they are considered equal! This
should, however, happen only in extremely rare cases!
(Overrides ObjectGetHashCode.) |
![]() | Length |
Returns the length of a line segment.
|

Name | Description | |
---|---|---|
![]() ![]() | Equality |
Checks the equality of two line segments.
|
![]() ![]() | Inequality |
Checks the inequality of two line segments.
|