API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Line Constructor (Point, Point)

Instantiates a line defined by the given points.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public Line(
	Point p1,
	Point p2
)

Parameters

p1
Type: Tekla.Structures.Geometry3dPoint
The first point to be used.
p2
Type: Tekla.Structures.Geometry3dPoint
The second point to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.