API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IntersectionPlaneToPlane Method

Returns a new line which is an intersection of the given two planes or null if the planes are parallel.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static Line PlaneToPlane(
	GeometricPlane plane1,
	GeometricPlane plane2
)

Parameters

plane1
Type: Tekla.Structures.Geometry3dGeometricPlane
The first plane to be used.
plane2
Type: Tekla.Structures.Geometry3dGeometricPlane
The second plane to be used.

Return Value

Type: Line
The intersection line or null if no intersection was found.
See Also