API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IntersectionLineToObb Method

Returns a new line segment which is an intersection of the given line and the oriented bounding box or null if the line and oriented bounding box do not intersect.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static LineSegment LineToObb(
	Line line,
	OBB obb
)

Parameters

line
Type: Tekla.Structures.Geometry3dLine
Line to be used.
obb
Type: Tekla.Structures.Geometry3dOBB
Oriented bounding box to be used.

Return Value

Type: LineSegment
The intersection line segment or null if no intersection was found.
See Also